mixer app: bump to latest revision when 4A is enabled
[AGL/meta-agl-demo.git] / recipes-demo-hmi / mixer / mixer_git.bb
1 SUMMARY     = "Mixer for CES2017 AGL Demonstration"
2 DESCRIPTION = "AGL HMI application for control of PulseAudio mixer elements"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/mixer"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mixer;protocol=https;branch=${AGL_BRANCH}"
10
11 # 'legacy' version (eel_5.0.3) when 4A is not enabled
12 SRCREV  = "eel_5.0.3"
13 # 4A-aware mixer
14 SRVREV_agl-audio-4a-framework = "${AGL_APP_REVISION}"
15
16 PV = "1.0+git${SRCPV}"
17 S  = "${WORKDIR}/git"
18
19 # build-time dependencies
20 DEPENDS += "qtquickcontrols2 \
21             pulseaudio \
22             virtual/libhomescreen \
23             qlibwindowmanager \
24 "
25
26 inherit qmake5 aglwgt