c7f30a16469ebdcad841bb7683b42814a0da2b1e
[AGL/meta-agl-demo.git] / recipes-demo-hmi / mixer / mixer_git.bb
1 SUMMARY     = "Mixer for CES2017 AGL Demonstration"
2 DESCRIPTION = "AGL HMI application for control of PulseAudio mixer elements"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/mixer"
4 LICENSE     = "Apache-2.0"
5 SECTION     = "apps"
6
7 PV = "1.0+git${SRCPV}"
8 S  = "${WORKDIR}/git"
9
10 inherit qmake5
11
12 DEPENDS += "qtquickcontrols2"
13 # 'wgtpkg-pack' in af-main-native is required.
14 DEPENDS += "af-main-native"
15 DEPENDS += "pulseaudio"
16
17 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
18
19 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mixer;protocol=http"
20 SRCREV  = "${AUTOREV}"
21
22 RDEPENDS_${PN} += " \
23     qtmultimedia-qmlplugins \
24     qtquickcontrols2-qmlplugins \
25     "
26
27 do_install() {
28     install -d ${D}/usr/AGL/apps
29     install -m 0644 ${B}/package/${PN}.wgt ${D}/usr/AGL/apps/
30 }
31
32 FILES_${PN} += "/usr/AGL/apps/ \
33     /usr/AGL/apps/${PN} \
34     "