Make sure app recipes use the release versions
[AGL/meta-agl-demo.git] / recipes-demo-hmi / libhomescreen / libhomescreen_git.bb
1 SUMMARY     = "AGL Home Screen Library"
2 DESCRIPTION = "libhomescreen"
3 HOMEPAGE    = "http://docs.automotivelinux.org"
4 LICENSE     = "Apache-2.0"
5 SECTION     = "libs"
6 S           = "${WORKDIR}/git/"
7
8 BBCLASSEXTEND = " nativesdk"
9
10 inherit qmake5 pkgconfig
11
12 DEPENDS += " glib-2.0 "
13
14 LIC_FILES_CHKSUM = "file://libhomescreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
15
16 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/libhomescreen.git;protocol=https;branch=dab \
17            file://homescreen.pc.in"
18
19 SRCREV = "adf78ab9e5d9b82e3462bc0d7f928bd2d7085c0e"
20 SRCREV_dab = "refs/tags/${DISTRO_BRANCH_VERSION_TAG}"
21
22 # PV needs to be modified with SRCPV to work AUTOREV correctly
23 PV = "0.0+git${SRCPV}"
24
25 do_install() {
26     install -d ${D}/usr/AGL/${PN}
27     install -m 0755 ${B}/samplehomescreeninterfaceapp/SampleHomeScreenInterfaceApp ${D}/usr/AGL/${PN}/
28
29     install -d ${D}${libdir}
30     install -m 0644 ${B}/libhomescreen/libhomescreen.so.1.0.0 ${D}${libdir}/
31     ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so
32     ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1
33     ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1.0
34
35 # kooltux: still some problem with paths inside .pc file
36 # error at build time:
37 # ERROR: homescreen-git-r0 do_populate_sysroot: QA Issue: homescreen.pc failed sanity test (tmpdir) in path /xdt/build/tmp/work/cortexa15hf-neon-agl-linux-gnueabi/libhomescreen/git-r0/sysroot-destdir/usr/lib/pkgconfig [pkgconfig]
38 #
39     install -d ${D}${libdir}/pkgconfig
40     install -m 0644 ${WORKDIR}/homescreen.pc.in ${D}${libdir}/pkgconfig/homescreen.pc
41     sed -i s:OEPREFIX:${prefix}:g ${D}${libdir}/pkgconfig/homescreen.pc
42     sed -i s:OELIBDIR:${libdir}:g ${D}${libdir}/pkgconfig/homescreen.pc
43     sed -i s:OEINCDIR:${includedir}:g ${D}${libdir}/pkgconfig/homescreen.pc
44
45     install -d ${D}${includedir}
46     install -m 0644 ${S}/libhomescreen/include/libhomescreen.hpp ${D}${includedir}/
47 }
48
49 PACKAGES =+ "libhomescreensampleapp libhomescreensampleapp-dbg"
50
51 FILES_${PN} = "\
52         ${libdir}/libhomescreen.so.* \
53 "
54 FILES_${PN}-dev = "\
55         ${includedir}/libhomescreen.hpp \
56         ${libdir}/libhomescreen.so \
57         ${libdir}/pkgconfig/homescreen.pc \
58 "
59 FILES_${PN}-dbg += "\
60         ${libdir}/.debug/libhomescreen.so.* \
61 "
62
63 FILES_libhomescreensampleapp += "/usr/AGL/${PN}/SampleHomeScreenInterfaceApp"
64 FILES_libhomescreensampleapp-dbg += "/usr/AGL/${PN}/.debug"
65
66
67 RDEPENDS_libhomescreensampleapp-dbg += "${PN}-dbg ${PN}-dev"
68