Add PROVIDES into libhomescreen bb files
[AGL/meta-agl-demo.git] / recipes-demo-hmi / libhomescreen / libhomescreen_git.bb
1 SUMMARY     = "AGL Home Screen Library"
2 DESCRIPTION = "libhomescreen"
3 HOMEPAGE    = "http://docs.automotivelinux.org"
4 LICENSE     = "Apache-2.0"
5 SECTION     = "libs"
6
7 BBCLASSEXTEND = " nativesdk"
8
9 LIC_FILES_CHKSUM = "file://libhomescreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
10
11 DEPENDS += " glib-2.0 "
12
13 inherit qmake5 pkgconfig
14
15 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/libhomescreen.git;protocol=https;branch=${AGL_BRANCH} \
16            file://homescreen.pc.in"
17 SRCREV  = "f5c14333d2170ae9babed53ea530828569a830ff"
18 S       = "${WORKDIR}/git/"
19
20 # PV needs to be modified with SRCPV to work AUTOREV correctly
21 PV = "0.0+git${SRCPV}"
22
23 do_install() {
24     install -d ${D}/usr/AGL/${PN}
25     install -m 0755 ${B}/samplehomescreeninterfaceapp/SampleHomeScreenInterfaceApp ${D}/usr/AGL/${PN}/
26
27     install -d ${D}${libdir}
28     install -m 0644 ${B}/libhomescreen/libhomescreen.so.1.0.0 ${D}${libdir}/
29     ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so
30     ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1
31     ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1.0
32
33 # kooltux: still some problem with paths inside .pc file
34 # error at build time:
35 # ERROR: homescreen-git-r0 do_populate_sysroot: QA Issue: homescreen.pc failed sanity test (tmpdir) in path /xdt/build/tmp/work/cortexa15hf-neon-agl-linux-gnueabi/libhomescreen/git-r0/sysroot-destdir/usr/lib/pkgconfig [pkgconfig]
36 #
37     install -d ${D}${libdir}/pkgconfig
38     install -m 0644 ${WORKDIR}/homescreen.pc.in ${D}${libdir}/pkgconfig/homescreen.pc
39     sed -i s:OEPREFIX:${prefix}:g ${D}${libdir}/pkgconfig/homescreen.pc
40     sed -i s:OELIBDIR:${libdir}:g ${D}${libdir}/pkgconfig/homescreen.pc
41     sed -i s:OEINCDIR:${includedir}:g ${D}${libdir}/pkgconfig/homescreen.pc
42
43     install -d ${D}${includedir}
44     install -m 0644 ${S}/libhomescreen/include/libhomescreen.hpp ${D}${includedir}/
45 }
46
47 PACKAGES =+ "libhomescreensampleapp libhomescreensampleapp-dbg"
48
49 FILES_${PN} = "\
50         ${libdir}/libhomescreen.so.* \
51 "
52 FILES_${PN}-dev = "\
53         ${includedir}/libhomescreen.hpp \
54         ${libdir}/libhomescreen.so \
55         ${libdir}/pkgconfig/homescreen.pc \
56 "
57 FILES_${PN}-dbg += "\
58         ${libdir}/.debug/libhomescreen.so.* \
59 "
60
61 FILES_libhomescreensampleapp += "/usr/AGL/${PN}/SampleHomeScreenInterfaceApp"
62 FILES_libhomescreensampleapp-dbg += "/usr/AGL/${PN}/.debug"
63
64
65 RDEPENDS_libhomescreensampleapp-dbg += "${PN}-dbg ${PN}-dev"
66 PROVIDES += "virtual/libhomescreen"