440ea420e72fbb9717ec63a14a0d1a119c61101e
[AGL/meta-agl-demo.git] / recipes-demo-hmi / libhomescreen / libhomescreen_git.bb
1 SUMMARY     = "AGL Home Screen Library"
2 DESCRIPTION = "libhomescreen"
3 HOMEPAGE    = "http://docs.automotivelinux.org"
4 LICENSE     = "Apache-2.0"
5 SECTION     = "libs"
6 S           = "${WORKDIR}/git/"
7
8 BBCLASSEXTEND = " nativesdk"
9
10 inherit qmake5 pkgconfig
11
12 DEPENDS += " glib-2.0 "
13
14 LIC_FILES_CHKSUM = "file://libhomescreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
15 SRCREV  = "${AUTOREV}"
16 # PV needs to be modified with SRCPV to work AUTOREV correctly
17 PV = "0.0+git${SRCPV}"
18
19 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/libhomescreen.git;protocol=http \
20            file://homescreen.pc.in"
21
22 do_install() {
23     install -d ${D}/usr/AGL/${PN}
24     install -m 0755 ${B}/samplehomescreeninterfaceapp/SampleHomeScreenInterfaceApp ${D}/usr/AGL/${PN}/
25
26     install -d ${D}${libdir}
27     install -m 0644 ${B}/libhomescreen/libhomescreen.so.1.0.0 ${D}${libdir}/
28     ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so
29     ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1
30     ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1.0
31
32 # kooltux: still some problem with paths inside .pc file
33 # error at build time:
34 # ERROR: homescreen-git-r0 do_populate_sysroot: QA Issue: homescreen.pc failed sanity test (tmpdir) in path /xdt/build/tmp/work/cortexa15hf-neon-agl-linux-gnueabi/libhomescreen/git-r0/sysroot-destdir/usr/lib/pkgconfig [pkgconfig]
35 #
36     install -d ${D}${libdir}/pkgconfig
37     install -m 0644 ${WORKDIR}/homescreen.pc.in ${D}${libdir}/pkgconfig/homescreen.pc
38     sed -i s:OEPREFIX:${prefix}:g ${D}${libdir}/pkgconfig/homescreen.pc
39     sed -i s:OELIBDIR:${libdir}:g ${D}${libdir}/pkgconfig/homescreen.pc
40     sed -i s:OEINCDIR:${includedir}:g ${D}${libdir}/pkgconfig/homescreen.pc
41
42     install -d ${D}${includedir}
43     install -m 0644 ${S}/libhomescreen/include/libhomescreen.hpp ${D}${includedir}/
44 }
45
46 PACKAGES =+ "libhomescreensampleapp libhomescreensampleapp-dbg"
47
48 FILES_${PN} = "\
49         ${libdir}/libhomescreen.so.* \
50 "
51 FILES_${PN}-dev = "\
52         ${includedir}/libhomescreen.hpp \
53         ${libdir}/libhomescreen.so \
54         ${libdir}/pkgconfig/homescreen.pc \
55 "
56 FILES_${PN}-dbg += "\
57         ${libdir}/.debug/libhomescreen.so.* \
58 "
59
60 FILES_libhomescreensampleapp += "/usr/AGL/${PN}/SampleHomeScreenInterfaceApp"
61 FILES_libhomescreensampleapp-dbg += "/usr/AGL/${PN}/.debug"
62
63
64 RDEPENDS_libhomescreensampleapp-dbg += "${PN}-dbg ${PN}-dev"
65