7f6ded29ecc573129637517fcd5d6ae02e18b450
[AGL/meta-agl-demo.git] / recipes-demo-hmi / inputeventmanager / inputeventmanager_git.bb
1 SUMMARY     = "AGL InputEventManager Application"
2 DESCRIPTION = "InputEventManager"
3 HOMEPAGE    = "http://docs.automotivelinux.org"
4 LICENSE     = "Apache-2.0"
5 SECTION     = "apps"
6 S           = "${WORKDIR}/git/"
7
8 inherit qmake5 systemd
9 DEPENDS = " qtbase "
10
11 LIC_FILES_CHKSUM = "file://inputeventmanager/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
12
13 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/inputeventmanager.git;protocol=https;branch=${AGL_BRANCH}"
14 SRCREV  = "b2f1646ac78cf61acd66c643b7638bd1b007d5a0"
15 # PV needs to be modified with SRCPV to work AUTOREV correctly
16 PV = "0.0+git${SRCPV}"
17
18 PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
19
20 do_install() {
21     install -d ${D}/usr/AGL/${PN}
22     install -m 0755 ${B}/inputeventmanager/InputEventManager ${D}/usr/AGL/${PN}/
23     
24     install -d ${D}${systemd_user_unitdir}
25     install -m 0644 ${S}/inputeventmanager/conf/InputEventManager.service ${D}${systemd_user_unitdir}
26 }
27
28 FILES_${PN} += "/usr/AGL/${PN}/ ${systemd_user_unitdir}"
29 FILES_${PN}-dbg += "/usr/AGL/${PN}/.debug"
30