Make sure app recipes use the release versions
[AGL/meta-agl-demo.git] / recipes-demo-hmi / inputeventmanager / inputeventmanager_git.bb
1 SUMMARY     = "AGL InputEventManager Application"
2 DESCRIPTION = "InputEventManager"
3 HOMEPAGE    = "http://docs.automotivelinux.org"
4 LICENSE     = "Apache-2.0"
5 SECTION     = "apps"
6 S           = "${WORKDIR}/git/"
7
8 inherit qmake5 systemd
9 DEPENDS = " qtbase "
10
11 LIC_FILES_CHKSUM = "file://inputeventmanager/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
12
13 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/inputeventmanager.git;protocol=https;branch=dab"
14
15 SRCREV = "b39053a5a8512a735ac154ddbd7dba3ceeadce3e"
16 SRCREV_dab = "refs/tags/${DISTRO_BRANCH_VERSION_TAG}"
17
18
19 # PV needs to be modified with SRCPV to work AUTOREV correctly
20 PV = "0.0+git${SRCPV}"
21
22 PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
23
24 do_install() {
25     install -d ${D}/usr/AGL/${PN}
26     install -m 0755 ${B}/inputeventmanager/InputEventManager ${D}/usr/AGL/${PN}/
27     
28     install -d ${D}${systemd_user_unitdir}
29     install -m 0644 ${S}/inputeventmanager/conf/InputEventManager.service ${D}${systemd_user_unitdir}
30 }
31
32 FILES_${PN} += "/usr/AGL/${PN}/ ${systemd_user_unitdir}"
33 FILES_${PN}-dbg += "/usr/AGL/${PN}/.debug"
34