html5-mediaplayer: create recipe and add to html5 demo
[AGL/meta-agl-demo.git] / recipes-demo-hmi / html5-mediaplayer / html5-mediaplayer_git.bb
1 SUMMARY     = "AGL HTML5 Mediaplayer Application"
2 HOMEPAGE    = "https://git.automotivelinux.org/apps/html5-mediaplayer/"
3 SECTION     = "apps"
4 LICENSE     = "Apache-2.0"
5 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7 PV      = "1.0+git${SRCPV}"
8 S       = "${WORKDIR}/git/"
9
10 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-mediaplayer;protocol=https;branch=${AGL_BRANCH}"
11 SRCREV = "${AGL_APP_REVISION}"
12
13 DEPENDS += " nodejs-native"
14
15 inherit aglwgt
16
17 do_configure() {
18   cd ${B}
19   npm install
20 }
21
22 do_aglwgt_package()  {
23   cd ${B}
24   npm run build
25 }