Remove colorschemes since no longer needed
[AGL/meta-agl-demo.git] / recipes-demo-hmi / homescreen / homescreen_git.bb
1 SUMMARY     = "AGL Home Screen Application"
2 DESCRIPTION = "AGL Home Screen Application + SampleAppTimeDate + HomeScreenAppFrameworkBinderAGL + WindowManager + InputEventManager + two sample apps (QML and Qtwidget)"
3 HOMEPAGE    = "https://wiki.automotivelinux.org/homescreen"
4 LICENSE     = "Apache-2.0"
5 SECTION     = "apps"
6 S           = "${WORKDIR}/git/"
7
8 inherit qmake5 systemd
9 DEPENDS = " qtbase "
10
11 # for HomeScreenAppFrameworkBinderTizen:
12 #DEPENDS += " pkgmgr-info aul "
13 # for WindowManager:
14 DEPENDS += " wayland-ivi-extension "
15 # for libhomescreen
16 DEPENDS += " glib-2.0 "
17 # for sample apps
18 DEPENDS += " qtdeclarative qtquickcontrols2 "
19
20 LIC_FILES_CHKSUM = "file://HomeScreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
21 SRCREV  = "${AUTOREV}"
22 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/staging/HomeScreen.git;protocol=http"
23
24 PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
25
26 do_install() {
27     install -d ${D}/usr/AGL/${PN}
28     install -m 0755 ${B}/HomeScreen/HomeScreen ${D}/usr/AGL/${PN}/
29     install -m 0755 ${B}/SampleAppTimeDate/SampleAppTimeDate ${D}/usr/AGL/${PN}/
30     install -m 0755 ${B}/SampleHomeScreenInterfaceApp/SampleHomeScreenInterfaceApp ${D}/usr/AGL/${PN}/
31     install -m 0755 ${B}/HomeScreenAppFrameworkBinderAGL/HomeScreenAppFrameworkBinderAGL ${D}/usr/AGL/${PN}/
32     install -m 0755 ${B}/WindowManager/WindowManager ${D}/usr/AGL/${PN}/
33     install -m 0755 ${B}/InputEventManager/InputEventManager ${D}/usr/AGL/${PN}/
34     install -m 0755 ${B}/SampleNavigationApp/SampleNavigationApp ${D}/usr/AGL/${PN}/
35     install -m 0755 ${B}/SampleMediaApp/SampleMediaApp ${D}/usr/AGL/${PN}/
36     
37     install -d ${D}${libdir}
38     install -m 0644 ${B}/libhomescreen/libhomescreen.so.1.0.0 ${D}${libdir}/
39     ln -sf ${libdir}/libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so
40     ln -sf ${libdir}/libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1
41     ln -sf ${libdir}/libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1.0
42
43
44     install -d ${D}${systemd_user_unitdir}
45     install -m 0644 ${S}/HomeScreen/conf/HomeScreen.service ${D}${systemd_user_unitdir}
46     install -m 0644 ${S}/HomeScreenAppFrameworkBinderAGL/conf/HomeScreenAppFrameworkBinderAGL.service ${D}${systemd_user_unitdir}
47     install -m 0644 ${S}/InputEventManager/conf/InputEventManager.service ${D}${systemd_user_unitdir}
48     install -m 0644 ${S}/WindowManager/conf/WindowManager.service ${D}${systemd_user_unitdir}
49
50     install -d ${D}${sysconfdir}/systemd/user/default.target.wants
51     ln -sf ${systemd_user_unitdir}/WindowManager.service ${D}${sysconfdir}/systemd/user/default.target.wants
52     ln -sf ${systemd_user_unitdir}/HomeScreen.service ${D}${sysconfdir}/systemd/user/default.target.wants
53 }
54
55 FILES_${PN} += "/usr/AGL/${PN}/ ${libdir} ${systemd_user_unitdir}"
56 FILES_${PN}-dbg += "/usr/AGL/${PN}/.debug"
57
58
59 #############################################
60 # this has to be set up later...
61 #############################################
62 #PACKAGES =+ "libhomescreen libhomescreen-dev libhomescreen-dbg"
63 #
64 #FILES_libhomescreen = "\
65 #       ${libdir}/libhomescreen.so.* \
66 #"
67 #FILES_libhomescreen-dev = "\
68 #       ${includedir}/libhomescreen.hpp \
69 #       ${libdir}/libhomescreen.so \
70 #       ${libdir}/pkgconfig/libhomescreen.pc \
71 #"
72 #FILES_libhomescreen-dbg = "\
73 #       ${libdir}/.debug/libhomescreen.so.* \
74 #"
75 #RDEPENDS_libhomescreen-dbg += "${PN}-dbg libhomescreen-dev"
76 #
77 #RDEPENDS_${PN}-dev += "libhomescreen-dev"
78