homescreen: generate appropriate files for SDK
[AGL/meta-agl-demo.git] / recipes-demo-hmi / homescreen / homescreen_git.bb
1 SUMMARY     = "AGL Home Screen Application"
2 DESCRIPTION = "AGL Home Screen Application + SampleAppTimeDate + HomeScreenAppFrameworkBinderAGL + WindowManager + InputEventManager + two sample apps (QML and Qtwidget)"
3 HOMEPAGE    = "https://wiki.automotivelinux.org/homescreen"
4 LICENSE     = "Apache-2.0"
5 SECTION     = "apps"
6 S           = "${WORKDIR}/git/"
7
8 BBCLASSEXTEND = " nativesdk"
9
10 inherit qmake5 systemd
11 DEPENDS = " qtbase "
12
13 # for HomeScreenAppFrameworkBinderTizen:
14 #DEPENDS += " pkgmgr-info aul "
15 # for WindowManager:
16 DEPENDS += " wayland-ivi-extension "
17 # for libhomescreen
18 DEPENDS += " glib-2.0 "
19 # for sample apps
20 DEPENDS += " qtdeclarative qtquickcontrols2 "
21
22 LIC_FILES_CHKSUM = "file://HomeScreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
23 SRCREV  = "${AUTOREV}"
24 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/staging/HomeScreen.git;protocol=http"
25
26 PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
27
28 do_install() {
29     install -d ${D}/usr/AGL/${PN}
30     install -m 0755 ${B}/HomeScreen/HomeScreen ${D}/usr/AGL/${PN}/
31     install -m 0755 ${B}/SampleAppTimeDate/SampleAppTimeDate ${D}/usr/AGL/${PN}/
32     install -m 0755 ${B}/SampleHomeScreenInterfaceApp/SampleHomeScreenInterfaceApp ${D}/usr/AGL/${PN}/
33     install -m 0755 ${B}/HomeScreenAppFrameworkBinderAGL/HomeScreenAppFrameworkBinderAGL ${D}/usr/AGL/${PN}/
34     install -m 0755 ${B}/WindowManager/WindowManager ${D}/usr/AGL/${PN}/
35     install -m 0755 ${B}/InputEventManager/InputEventManager ${D}/usr/AGL/${PN}/
36     install -m 0755 ${B}/SampleNavigationApp/SampleNavigationApp ${D}/usr/AGL/${PN}/
37     install -m 0755 ${B}/SampleMediaApp/SampleMediaApp ${D}/usr/AGL/${PN}/
38     
39     install -d ${D}${libdir}
40     install -m 0644 ${B}/libhomescreen/libhomescreen.so.1.0.0 ${D}${libdir}/
41     ln -sf ${libdir}/libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so
42     ln -sf ${libdir}/libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1
43     ln -sf ${libdir}/libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1.0
44
45
46     install -d ${D}${systemd_user_unitdir}
47     install -m 0644 ${S}/HomeScreen/conf/HomeScreen.service ${D}${systemd_user_unitdir}
48     install -m 0644 ${S}/HomeScreenAppFrameworkBinderAGL/conf/HomeScreenAppFrameworkBinderAGL.service ${D}${systemd_user_unitdir}
49     install -m 0644 ${S}/InputEventManager/conf/InputEventManager.service ${D}${systemd_user_unitdir}
50     install -m 0644 ${S}/WindowManager/conf/WindowManager.service ${D}${systemd_user_unitdir}
51
52     install -d ${D}${sysconfdir}/systemd/user/default.target.wants
53     ln -sf ${systemd_user_unitdir}/WindowManager.service ${D}${sysconfdir}/systemd/user/default.target.wants
54     ln -sf ${systemd_user_unitdir}/HomeScreen.service ${D}${sysconfdir}/systemd/user/default.target.wants
55 }
56
57 FILES_${PN} += "/usr/AGL/${PN}/ ${libdir} ${systemd_user_unitdir}"
58 FILES_${PN}-dbg += "/usr/AGL/${PN}/.debug"
59
60
61 PACKAGES =+ "libhomescreen libhomescreen-dev libhomescreen-dbg"
62
63 FILES_libhomescreen = "\
64         ${libdir}/libhomescreen.so.* \
65 "
66 FILES_libhomescreen-dev = "\
67         ${includedir}/libhomescreen.hpp \
68         ${libdir}/libhomescreen.so \
69         ${libdir}/pkgconfig/libhomescreen.pc \
70 "
71 FILES_libhomescreen-dbg = "\
72         ${libdir}/.debug/libhomescreen.so.* \
73 "
74 RDEPENDS_libhomescreen-dbg += "${PN}-dbg libhomescreen-dev"
75
76 RDEPENDS_${PN}-dev += "libhomescreen-dev"
77