These recipes were in need of a repin for chinook 3.0.2
[AGL/meta-agl-demo.git] / recipes-demo-hmi / homescreen / homescreen_git.bb
1 SUMMARY     = "AGL Home Screen Application"
2 DESCRIPTION = "AGL Home Screen Application + SampleAppTimeDate + HomeScreenAppFrameworkBinderAGL + WindowManager + InputEventManager"
3 HOMEPAGE    = "https://wiki.automotivelinux.org/homescreen"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://HomeScreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9
10 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/staging/HomeScreen.git;protocol=http \
11            file://homescreen.pc.in \
12            file://dbus-homescreen.conf.in"
13 SRCREV  = "${AUTOREV}"
14
15 # Pinned SRCREV for Charming Chinook, staging projects do not follow release branches
16 SRCREV_chinook = "3b5d0701a25b19ee2ac91d7466652c8fc4025db0"
17
18
19 # PV needs to be modified with SRCPV to work AUTOREV correctly
20 PV = "0.0+git${SRCPV}"
21 # git repository used
22 S           = "${WORKDIR}/git/"
23
24 DEPENDS += " qtbase "
25 # for HomeScreenAppFrameworkBinderTizen:
26 #DEPENDS += " pkgmgr-info aul "
27 # for WindowManager:
28 DEPENDS += " wayland-ivi-extension "
29 # for libhomescreen
30 DEPENDS += " glib-2.0 "
31 # for sample apps
32 DEPENDS += " qtdeclarative qtquickcontrols2 "
33
34
35 inherit qmake5 systemd pkgconfig
36
37
38 PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
39
40 do_install() {
41     install -d ${D}/usr/AGL/${PN}
42     install -m 0755 ${B}/HomeScreen/HomeScreen ${D}/usr/AGL/${PN}/
43     install -m 0755 ${B}/SampleAppTimeDate/SampleAppTimeDate ${D}/usr/AGL/${PN}/
44     install -m 0755 ${B}/SampleHomeScreenInterfaceApp/SampleHomeScreenInterfaceApp ${D}/usr/AGL/${PN}/
45     install -m 0755 ${B}/HomeScreenAppFrameworkBinderAGL/HomeScreenAppFrameworkBinderAGL ${D}/usr/AGL/${PN}/
46     install -m 0755 ${B}/WindowManager/WindowManager ${D}/usr/AGL/${PN}/
47     install -m 0755 ${B}/InputEventManager/InputEventManager ${D}/usr/AGL/${PN}/
48     
49     install -d ${D}${libdir}
50     install -m 0644 ${B}/libhomescreen/libhomescreen.so.1.0.0 ${D}${libdir}/
51     ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so
52     ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1
53     ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1.0
54
55 # claneys: add dbus policy to make wifi/bluetooth status icon working as quick 
56 # workaround. (jira.automotivelinux.org : SPEC-377)
57     install -d ${D}/etc/dbus-1/session.d
58     install -m 0644 ${WORKDIR}/dbus-homescreen.conf.in ${D}/etc/dbus-1/session.d/homescreen.conf
59
60 # kooltux: still some problem with paths inside .pc file
61 # error at build time:
62 # ERROR: homescreen-git-r0 do_populate_sysroot: QA Issue: homescreen.pc failed sanity test (tmpdir) in path /xdt/build/tmp/work/cortexa15hf-neon-agl-linux-gnueabi/homescreen/git-r0/sysroot-destdir/usr/lib/pkgconfig [pkgconfig]
63 #
64     install -d ${D}${libdir}/pkgconfig
65     install -m 0644 ${WORKDIR}/homescreen.pc.in ${D}${libdir}/pkgconfig/homescreen.pc
66     sed -i s:OEPREFIX:${prefix}:g ${D}${libdir}/pkgconfig/homescreen.pc
67     sed -i s:OELIBDIR:${libdir}:g ${D}${libdir}/pkgconfig/homescreen.pc
68     sed -i s:OEINCDIR:${includedir}:g ${D}${libdir}/pkgconfig/homescreen.pc
69
70         install -d ${D}${includedir}
71         install -m 0644 ${S}/libhomescreen/include/libhomescreen.hpp ${D}${includedir}/
72
73     install -d ${D}${systemd_user_unitdir}
74     install -m 0644 ${S}/HomeScreen/conf/HomeScreen.service ${D}${systemd_user_unitdir}
75     install -m 0644 ${S}/HomeScreenAppFrameworkBinderAGL/conf/HomeScreenAppFrameworkBinderAGL.service ${D}${systemd_user_unitdir}
76     install -m 0644 ${S}/InputEventManager/conf/InputEventManager.service ${D}${systemd_user_unitdir}
77     install -m 0644 ${S}/WindowManager/conf/WindowManager.service ${D}${systemd_user_unitdir}
78
79     install -d ${D}${sysconfdir}/systemd/user/default.target.wants
80     ln -sf ${systemd_user_unitdir}/WindowManager.service ${D}${sysconfdir}/systemd/user/default.target.wants
81     ln -sf ${systemd_user_unitdir}/HomeScreen.service ${D}${sysconfdir}/systemd/user/default.target.wants
82 }
83
84 FILES_${PN} += "/usr/AGL/${PN}/ ${libdir} ${systemd_user_unitdir}"
85 FILES_${PN}-dbg += "/usr/AGL/${PN}/.debug"
86
87
88 PACKAGES =+ "libhomescreen libhomescreen-dev libhomescreen-dbg"
89
90 FILES_libhomescreen = "\
91         ${libdir}/libhomescreen.so.* \
92 "
93 FILES_libhomescreen-dev = "\
94         ${includedir}/libhomescreen.hpp \
95         ${libdir}/libhomescreen.so \
96         ${libdir}/pkgconfig/homescreen.pc \
97 "
98 FILES_libhomescreen-dbg = "\
99         ${libdir}/.debug/libhomescreen.so.* \
100 "
101 RDEPENDS_libhomescreen-dbg += "${PN}-dbg libhomescreen-dev"
102
103 RDEPENDS_${PN}-dev += "libhomescreen-dev"
104
105
106 BBCLASSEXTEND = " nativesdk"