Make sure app recipes use the release versions
[AGL/meta-agl-demo.git] / recipes-demo-hmi / homescreen / homescreen_git.bb
1 SUMMARY     = "AGL Home Screen Application"
2 DESCRIPTION = "AGL Home Screen Application + SampleAppTimeDate"
3 HOMEPAGE    = "http://docs.automotivelinux.org"
4 LICENSE     = "Apache-2.0"
5 SECTION     = "apps"
6 S           = "${WORKDIR}/git/"
7
8 inherit qmake5 systemd pkgconfig
9 DEPENDS = " qtbase qtdeclarative qtquickcontrols2 pulseaudio"
10 RDEPENDS_${PN} = " \
11         homescreenappframeworkbinderagl \
12         inputeventmanager \
13         windowmanager"
14
15 LIC_FILES_CHKSUM = "file://homescreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
16
17 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/apps/homescreen.git;protocol=https;branch=dab \
18            file://dbus-homescreen.conf.in"
19
20 SRCREV  = "b9889b160ecc43dcde07fe9d8a96373196c539ab"
21 SRCREV_dab = "refs/tags/${DISTRO_BRANCH_VERSION_TAG}"
22
23
24 # PV needs to be modified with SRCPV to work AUTOREV correctly
25 PV = "0.0+git${SRCPV}"
26
27 PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
28
29 do_install() {
30     install -d ${D}/usr/AGL/${PN}
31     install -m 0755 ${B}/homescreen/HomeScreen ${D}/usr/AGL/${PN}/
32     install -m 0755 ${B}/sampleapptimedate/SampleAppTimeDate ${D}/usr/AGL/${PN}/
33
34 # claneys: add dbus policy to make wifi/bluetooth status icon working as quick 
35 # workaround. (jira.automotivelinux.org : SPEC-377)
36     install -d ${D}/etc/dbus-1/session.d
37     install -m 0644 ${WORKDIR}/dbus-homescreen.conf.in ${D}/etc/dbus-1/session.d/homescreen.conf
38
39     install -d ${D}${systemd_user_unitdir}
40     install -m 0644 ${S}/homescreen/conf/HomeScreen.service ${D}${systemd_user_unitdir}
41
42     install -d ${D}${sysconfdir}/systemd/user/default.target.wants
43     ln -sf ${systemd_user_unitdir}/HomeScreen.service ${D}${sysconfdir}/systemd/user/default.target.wants
44 }
45
46 FILES_${PN} += "/usr/AGL/${PN}/ ${systemd_user_unitdir}"
47 FILES_${PN}-dbg += "/usr/AGL/${PN}/.debug"
48