b12bc0ffeeee75beaf10d24ec036ee44354a0531
[AGL/meta-agl-demo.git] / recipes-demo-hmi / can-lin / can-lin_0.2.bb
1 DESCRIPTION = "CAN-LIN Application"
2 LICENSE = "GPLv2"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4
5 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/most-can-demo-bin;protocol=https"
6 SRC_URI += "file://hvac-demo.service"
7
8 S = "${WORKDIR}/git"
9 SRCREV = "fd2101e277cb80eef4c6381924cfdc1d50087d12"
10
11 do_install() {
12         install -m 0755 -d ${D}${bindir}
13         install -m 0755 ${S}/OptoLyzerMoccaApp ${D}${bindir}
14         # Hack for vod service for RSE with most/hvac demo hardware
15
16         # vod-client is provided as binary stored and delivered in staging/most-can-demo-bin.
17         install -m 0755 -d ${D}/usr/AGL/most
18         install -m 0755 ${S}/vod-client ${D}/usr/AGL/most
19
20         # Install HVAC DEMO hardware startup systemd service (user)
21         if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
22             install -m 644 -p -D ${WORKDIR}/hvac-demo.service ${D}${systemd_user_unitdir}/hvac-demo.service
23         fi
24
25         # Execute install manually for root user on behalf of systemctl script
26         # because it doesn't support user mode of systemd.
27         install -m 0755 -d ${D}/home/root/.config/systemd/user/default.target.wants/
28         ln -sf ${systemd_user_unitdir}/hvac-demo.service ${D}/home/root/.config/systemd/user/default.target.wants/hvac-demo.service
29 }
30
31 FILES_${PN} += " \
32     ${bindir}/OptoLyzerMoccaApp \
33     /usr/AGL/most/vod-client \
34     ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/hvac-demo.service', '', d)} \
35     ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '/home/root/.config/systemd/user/default.target.wants/hvac-demo.service', '', d)} \
36     "