Use ROOT_HOME variable, not /home/root
[AGL/meta-agl-demo.git] / recipes-demo-hmi / can-lin / can-lin_0.2.bb
1 DESCRIPTION = "CAN-LIN Application"
2 LICENSE = "GPLv2"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4
5 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/most-can-demo-bin;protocol=https;branch=${AGL_BRANCH}"
6 SRC_URI += "file://hvac-demo.service"
7
8 S = "${WORKDIR}/git"
9 SRCREV = "fd2101e277cb80eef4c6381924cfdc1d50087d12"
10
11 # These binaries are currently for the porter kernel only
12 COMPATIBLE_MACHINE = "porter"
13
14 do_install() {
15         install -m 0755 -d ${D}${bindir}
16         install -m 0755 ${S}/OptoLyzerMoccaApp ${D}${bindir}
17         # Hack for vod service for RSE with most/hvac demo hardware
18
19         # vod-client is provided as binary stored and delivered in staging/most-can-demo-bin.
20         install -m 0755 -d ${D}/usr/AGL/most
21         install -m 0755 ${S}/vod-client ${D}/usr/AGL/most
22
23         # Install HVAC DEMO hardware startup systemd service (user)
24         if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
25             install -m 644 -p -D ${WORKDIR}/hvac-demo.service ${D}${systemd_user_unitdir}/hvac-demo.service
26         fi
27
28         # Execute install manually for root user on behalf of systemctl script
29         # because it doesn't support user mode of systemd.
30         install -m 0755 -d ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/
31         ln -sf ${systemd_user_unitdir}/hvac-demo.service ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/hvac-demo.service
32 }
33
34 FILES_${PN} += " \
35     ${bindir}/OptoLyzerMoccaApp \
36     /usr/AGL/most/vod-client \
37     ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/hvac-demo.service', '', d)} \
38     ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${ROOT_HOME}/.config/systemd/user/default.target.wants/hvac-demo.service', '', d)} \
39     "