Pin recipes for blowfish 2.0.3
[AGL/meta-agl-demo.git] / recipes-demo-hmi / CES2016-demo / CES2016-demo.bb
1 SUMMARY     = "Homescreen for the AGL Demonstrator @ CES2016"
2 DESCRIPTION = "Homescreen apps in QML format for the AGL Demonstrator @ CES2016"
3 HOMEPAGE    = "https://git.automotivelinux.org/gerrit/#/admin/projects/AGL/DemoApps/CES2016"
4
5 SECTION     = "apps"
6
7 LICENSE     = "MPL-2.0"
8 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
9
10 SRC_URI     = "git://git.automotivelinux.org/gerrit/AGL/DemoApps/CES2016;protocol=http;branch=blowfish"
11
12 SRCREV      = "6e048fa867650571cd1630908e6bd86828630d2f"
13 # for development use
14 #SRCREV      = "${AUTOREV}"
15
16 PV = "2.0.1"
17
18 RDEPENDS_${PN} += " \
19     qtmultimedia-qmlplugins \
20     qtquickcontrols-qmlplugins \
21     qtsvg-plugins \
22     "
23
24 # custom configure and install as these are just qml files
25
26 # we work in the git checkout ...
27 S = "${WORKDIR}/git"
28
29 do_configure() {
30     ls
31 }
32
33 # plain copy in own folder for now
34 do_install() {
35     mkdir -p ${D}/opt/AGL/CES2016/
36     cp -ar ./* ${D}/opt/AGL/CES2016/
37 }
38
39 FILES_${PN} = "/opt/AGL/"