Add bitbake recipe for the CES demo.
[AGL/meta-agl-demo.git] / recipes-demo-hmi / CES2016-demo / CES2016-demo.bb
1 SUMMARY     = "Homescreen for the AGL Demonstrator @ CES2016"
2 DESCRIPTION = "Homescreen apps in QML format for the AGL Demonstrator @ CES2016"
3 HOMEPAGE    = "https://git.automotivelinux.org/gerrit/#/admin/projects/AGL/DemoApps/CES2016"
4
5 SECTION     = "apps"
6
7 LICENSE     = "MPL-2.0"
8 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
9
10 SRC_URI     = "git://git.automotivelinux.org/gerrit/AGL/DemoApps/CES2016;protocol=http"
11 SRCREV      = "AUTOINC"
12
13 RDEPENDS_${PN}_append = "qtmultimedia qtquickcontrols"
14
15 # custom configure and install as these are just qml files
16
17 # we work in the git checkout ...
18 S = "${WORKDIR}/git"
19
20 do_configure() {
21     ls
22 }
23
24 # plain copy in own folder for now
25 do_install() {
26     mkdir -p ${D}/opt/AGL/CES2016/
27     cp -ar ./* ${D}/opt/AGL/CES2016/
28 }
29
30 FILES_${PN} = "/opt/AGL/"