fix recipes git source url
[AGL/meta-agl-demo.git] / recipes-demo-hmi / CES2016-demo / CES2016-demo.bb
1 SUMMARY     = "Homescreen for the AGL Demonstrator @ CES2016"
2 DESCRIPTION = "Homescreen apps in QML format for the AGL Demonstrator @ CES2016"
3 HOMEPAGE    = "https://git.automotivelinux.org/gerrit/#/admin/projects/AGL/DemoApps/CES2016"
4
5 SECTION     = "apps"
6
7 PN = "ces2016-demo"
8
9 LICENSE     = "MPL-2.0"
10 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
11
12 SRC_URI     = "git://gerrit.automotivelinux.org/gerrit/AGL/DemoApps/CES2016;protocol=http"
13 SRCREV      = "${AUTOREV}"
14
15 PV = "1.0+git"
16
17 RDEPENDS_${PN} += " \
18     qtmultimedia-qmlplugins \
19     qtquickcontrols-qmlplugins \
20     qtsvg-plugins \
21     "
22
23 # custom configure and install as these are just qml files
24
25 # we work in the git checkout ...
26 S = "${WORKDIR}/git"
27
28 do_configure() {
29     ls
30 }
31
32 # plain copy in own folder for now
33 do_install() {
34     mkdir -p ${D}/usr/AGL/CES2016/
35     cp -rf ./* ${D}/usr/AGL/CES2016/
36 }
37
38 FILES_${PN} = "/usr/AGL/"