24206bb78d9b5af45ce514c22e716e940feac784
[AGL/meta-agl-demo.git] / recipes-demo-hmi / CES2016-demo / CES2016-demo.bb
1 SUMMARY     = "Homescreen for the AGL Demonstrator @ CES2016"
2 DESCRIPTION = "Homescreen apps in QML format for the AGL Demonstrator @ CES2016"
3 HOMEPAGE    = "https://git.automotivelinux.org/gerrit/#/admin/projects/AGL/DemoApps/CES2016"
4
5 SECTION     = "apps"
6
7 LICENSE     = "MPL-2.0"
8 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
9
10 SRC_URI     = "git://git.automotivelinux.org/gerrit/AGL/DemoApps/CES2016;protocol=http"
11 SRCREV      = "${AUTOREV}"
12
13 PV = "1.0+git${SRCPV}"
14
15 RDEPENDS_${PN} += " \
16     qtmultimedia-qmlplugins \
17     qtquickcontrols-qmlplugins \
18     qtsvg-plugins \
19     "
20
21 # custom configure and install as these are just qml files
22
23 # we work in the git checkout ...
24 S = "${WORKDIR}/git"
25
26 do_configure() {
27     ls
28 }
29
30 # plain copy in own folder for now
31 do_install() {
32     mkdir -p ${D}/opt/AGL/CES2016/
33     cp -ar ./* ${D}/opt/AGL/CES2016/
34 }
35
36 FILES_${PN} = "/opt/AGL/"