[cef][wam] Make the recipe work with official chromium release tarballs
[AGL/meta-agl-demo.git] / recipes-connectivity / vss / vss_4.0.bb
1 SUMMARY = "Vehicle Signal Specification"
2 LICENSE = "MPL-2.0"
3 LIC_FILES_CHKSUM = "file://LICENSE;md5=9741c346eef56131163e13b9db1241b3"
4
5 DEPENDS = "vss-tools-native"
6
7 inherit allarch update-alternatives
8
9 require vss.inc
10
11 UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
12
13 S = "${WORKDIR}/git"
14
15 do_configure[noexec] = "1"
16
17 EXTRA_OEMAKE = "TOOLSDIR=${STAGING_BINDIR_NATIVE}"
18
19 do_compile() {
20     oe_runmake json
21 }
22
23 do_install() {
24     # Cannot use the "install" target in the project Makefile, as it is
25     # intended for setting the repo up for builds.
26     # For now, just the generated JSON is installed. It is possible that
27     # installing the vspec files somewhere as a development package may
28     # be useful, but for now things will be kept simple.
29     install -d ${D}${datadir}/vss
30     install -m 0644 ${S}/vss_rel_${PV}.json ${D}${datadir}/vss/
31 }
32
33 # NOTE:
34 # A virtual RPROVIDES is not used for now, as packages such as KUKSA.val
35 # provide their own copies of the VSS JSON, so we can install this one
36 # and any alternatives in parallel and point e.g. KUKSA.val at the desired
37 # file with a configuration change. This may be worth revisiting down the
38 # road.
39
40 ALTERNATIVE_LINK_NAME[vss.json] = "${datadir}/vss/vss.json"
41
42 ALTERNATIVE:${PN} = "vss.json"
43 ALTERNATIVE_TARGET_${PN} = "${datadir}/vss/vss_rel_${PV}.json"