Prepare master for new framework integration
[AGL/meta-agl-demo.git] / recipes-connectivity / rtl-sdr / rtl-sdr_0.5.3.bb
1 SUMMARY = "Turns a Realtek RTL2832U-based DVB dongle into a SDR receiver"
2 DESCRIPTION = "DVB-T dongles based on the Realtek RTL2832U chipset can be used as Software Digital Radio adapters, since the chip allows transferring raw I/Q samples to the host, which is really used for DAB/DAB+/FM demodulation."
3 HOMEPAGE = "http://sdr.osmocom.org/trac/wiki/rtl-sdr"
4
5 LICENSE = "GPLv2+"
6 LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
7                     file://src/librtlsdr.c;endline=18;md5=1b05599c3ebd4d74857a0a7c45f3d4ef"
8
9 DEPENDS = "libusb1"
10
11 SRC_URI = "git://git.osmocom.org/rtl-sdr;branch=master \
12            file://0001-remove-I-usr-include-in-pkg-config.patch \
13            "
14 SRCREV = "e3c03f738f5aef4dc51e2b741fbdb542b9cc1bb1"
15 S = "${WORKDIR}/git"
16
17 inherit autotools pkgconfig
18
19 EXTRA_OECONF = "--enable-driver-detach"
20
21 do_configure:append() {
22     # remove included temporary path from pc file due to pass-through of OE CFLAGS
23     # debug-prefix-map
24     # See: http://lists.openembedded.org/pipermail/openembedded-devel/2016-May/107456.html
25     sed -i -e "s# -fdebug-prefix-map=.*##g;s# -fmacro-prefix-map=.*##g" librtlsdr.pc
26 }