2a4026bd69fa6f3bf2c0f48e7c145c6831f864b0
[AGL/meta-agl-demo.git] / recipes-connectivity / kuksa-val / kuksa-viss-client_git.bb
1 SUMMARY = "Python client for KUKSA.val, the KUKSA Vehicle Abstraction Layer"
2 HOMEPAGE = "https://github.com/eclipse/kuksa.val"
3 BUGTRACKER = "https://github.com/eclipse/kuksa.val/issues"
4
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://../LICENSE;md5=2b42edef8fa55315f34f2370b4715ca9"
7
8 DEPENDS = " \
9     python3-setuptools-git-versioning-native \
10     python3-grpcio-tools-native \
11     python3-grpcio \
12 "
13
14 require kuksa-val.inc
15
16 SRC_URI += "file://0001-kuksa_viss_client-Update-cmd2-completer-usage.patch;striplevel=2"
17
18 S = "${WORKDIR}/git/kuksa_viss_client"
19
20 inherit python_setuptools_build_meta
21
22 RDEPENDS:${PN} += " \
23     python3-cmd2 \
24     python3-importlib-metadata \
25     python3-pkg-resources \
26     python3-pygments \
27     python3-websockets \
28     python3-grpcio \
29     python3-grpcio-tools \
30     python3-jsonpath-ng \
31 "
32
33 # A script for generating new certificates currently gets shipped inside
34 # the client module, for now add bash to RDEPENDS to quiet the QA error.
35 # This should probably be addressed with finer-grained packaging or some
36 # other change worked out with upstream.
37 RDEPENDS:${PN} += "bash"