Upgrade KUKSA.val components to 0.4.2 release
[AGL/meta-agl-demo.git] / recipes-connectivity / kuksa-val / kuksa-client_git.bb
1 SUMMARY = "Python client for KUKSA.val, the KUKSA Vehicle Abstraction Layer"
2 HOMEPAGE = "https://github.com/eclipse/kuksa.val"
3 BUGTRACKER = "https://github.com/eclipse/kuksa.val/issues"
4
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://../LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
7
8 DEPENDS = " \
9     python3-setuptools-git-versioning-native \
10     python3-grpcio-tools-native \
11     python3-grpcio \
12 "
13
14 PV = "0.4.2"
15
16 SRC_URI = "gitsm://github.com/eclipse-kuksa/kuksa-python-sdk.git;protocol=https;branch=main \
17            file://0001-kuksa-client-Update-cmd2-completer-usage.patch;patchdir=.. \
18            file://0002-kuksa-client-Add-external-certificates-support.patch;patchdir=.. \
19 "
20 SRCREV = "4ac107a638c8dbf5cde1743a3df2e28589990332"
21
22 S = "${WORKDIR}/git/kuksa-client"
23
24 inherit python_setuptools_build_meta
25
26 RDEPENDS:${PN} += " \
27     python3-cmd2 \
28     python3-importlib-metadata \
29     python3-pkg-resources \
30     python3-pygments \
31     python3-websockets \
32     python3-grpcio \
33     python3-grpcio-tools \
34     python3-jsonpath-ng \
35 "
36
37 # A script for generating new certificates currently gets shipped inside
38 # the client module, for now add bash to RDEPENDS to quiet the QA error.
39 # This should probably be addressed with finer-grained packaging or some
40 # other change worked out with upstream.
41 RDEPENDS:${PN} += "bash"