SPEC-3723: restructure meta-agl-demo
[AGL/meta-agl-demo.git] / recipes-connectivity / bluez-alsa / bluez-alsa_git.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/bluez-alsa:"
2
3 SRC_URI += "\
4     file://0001-utils-add-a-gstreamer-helper-application-for-interco.patch \
5     file://bluealsa-gst-helper@.service \
6     "
7
8 PACKAGECONFIG += "gsthelper"
9 PACKAGECONFIG[gsthelper] = "--enable-gsthelper, --disable-gsthelper, gstreamer1.0"
10
11 do_install_append() {
12     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
13         # install the service file
14         mkdir -p ${D}${systemd_system_unitdir}/
15         install -m 0644 ${WORKDIR}/bluealsa-gst-helper@.service ${D}${systemd_system_unitdir}/bluealsa-gst-helper@.service
16
17         # enable the helper to start together with afm-user-session
18         mkdir -p ${D}${systemd_system_unitdir}/afm-user-session@.target.wants
19         ln -sf ../bluealsa-gst-helper@.service ${D}${systemd_system_unitdir}/afm-user-session@.target.wants/bluealsa-gst-helper@.service
20     fi
21 }
22
23 PACKAGES =+ "${PN}-pipewire"
24
25 FILES_${PN}-pipewire = "\
26     ${bindir}/bluealsa-gst-helper \
27     ${systemd_system_unitdir}/bluealsa-gst-helper@.service \
28     ${systemd_system_unitdir}/afm-user-session@.target.wants/bluealsa-gst-helper@.service \
29     "
30 RDEPENDS_${PN}-pipewire += "\
31     bluez-alsa \
32     pipewire \
33     gstreamer1.0-plugins-base \
34     gstreamer1.0-pipewire \
35     "