Update github.com git:// SRC_URIs
[AGL/meta-agl-demo.git] / recipes-connectivity / bluez-alsa / bluez-alsa_git.bb
1 SUMMARY = "Bluetooth Audio ALSA Backend"
2 HOMEPAGE = "https://github.com/Arkq/bluez-alsa"
3 SECTION = "libs"
4
5 LICENSE = "MIT"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=3d7d6ac7e2dbd2505652dceb3acdf1fe"
7
8 SRC_URI = "git://github.com/Arkq/bluez-alsa.git;protocol=https;branch=master"
9 SRCREV = "2cd6e4686f7808276480b430fb37df55dfdcc02b"
10
11 SRC_URI += "file://bluez-alsa.service"
12
13 S  = "${WORKDIR}/git"
14
15 DEPENDS += "alsa-lib bluez5 systemd glib-2.0 sbc"
16
17 PACKAGECONFIG[aac]  = "--enable-aac, --disable-aac, "
18 PACKAGECONFIG[aptx] = "--enable-aptx,--disable-aptx,"
19 PACKAGECONFIG[ofono] = "--enable-ofono, --disable-ofono,"
20
21 inherit autotools pkgconfig
22 inherit systemd
23
24 SYSTEMD_AUTO_ENABLE = "enable"
25 SYSTEMD_SERVICE:${PN} = "bluez-alsa.service"
26
27 PACKAGECONFIG += "ofono"
28
29 # enable debug tools in devel images
30 PACKAGECONFIG[hcitop] = "--enable-hcitop, --disable-hcitop, libbsd ncurses"
31 PACKAGECONFIG[rfcomm] = "--enable-rfcomm, --disable-rfcomm,"
32 PACKAGECONFIG:append:agl-devel = " hcitop rfcomm"
33
34 do_install:append () {
35     install -d ${D}${base_libdir}/systemd/system
36     install -m 0644 ${WORKDIR}/bluez-alsa.service ${D}${base_libdir}/systemd/system
37 }
38
39 FILES:${PN} += "\
40    ${datadir}/alsa/alsa.conf.d/20-bluealsa.conf\
41    ${libdir}/alsa-lib/libasound_module_ctl_bluealsa.so\
42    ${libdir}/alsa-lib/libasound_module_pcm_bluealsa.so\
43 "