unicens-config: Add bash to rdeps
[AGL/meta-agl-demo.git] / recipes-config / unicens-config / unicens-config.bb
1 DESCRIPTION = "Configure MOST driver"
2 LICENSE = "GPLv2"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4
5 RDEPENDS_${PN} = "bash"
6
7 SRC_URI = "\
8     file://unicens-config.service \
9     file://unicens-config.sh \
10 "
11
12
13 inherit systemd
14
15 SYSTEMD_PACKAGES = "${PN}"
16 SYSTEMD_SERVICE_${PN} = "unicens-config.service"
17 SYSTEMD_AUTO_ENABLE_${PN} = "enable"
18
19 do_configure () {
20 }
21
22 do_compile() {
23 }
24
25 do_install() {
26     install -d ${D}${systemd_system_unitdir}
27     install -m 0644 ${WORKDIR}/unicens-config.service ${D}${systemd_system_unitdir}
28     install -d ${D}${bindir}
29     install -m 0755 ${WORKDIR}/unicens-config.sh ${D}${bindir}
30 }
31
32 FILES_${PN} += "${systemd_system_unitdir}"