1d5e0df224b7b23775202a6c207e065c998badd3
[AGL/meta-agl-demo.git] / recipes-config / qemu-config / qemu-config-agl-demo-platform.bb
1 SUMMARY     = "Setting files for agl-demo-plaform guest VM"
2 LICENSE     = "MIT"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4
5 inherit systemd allarch
6
7 SRC_URI = "file://${QEMU_IMAGE}.conf"
8
9 do_configure[noexec] = "1"
10 do_compile[noexec] = "1"
11
12 QEMU_IMAGE = "agl-demo-platform"
13 QEMU_UNIT = "agl-qemu-runner@${QEMU_IMAGE}.service"
14
15 do_install() {
16     # Install template unit links
17     install -d ${D}${systemd_system_unitdir}
18     ln -sf agl-qemu-runner@.service ${D}${systemd_system_unitdir}/${QEMU_UNIT}
19     install -d ${D}${systemd_system_unitdir}/multi-user.target.wants
20     ln -sf ${systemd_system_unitdir}/${QEMU_UNIT} ${D}${systemd_system_unitdir}/multi-user.target.wants/${QEMU_UNIT}
21
22     # Install conf file
23     install -d ${D}${sysconfdir}/agl-qemu-runner
24     install -m 0644 ${WORKDIR}/${QEMU_IMAGE}.conf ${D}${sysconfdir}/agl-qemu-runner/
25 }
26
27 FILES:${PN} += "${systemd_system_unitdir}"
28
29 RDEPENDS:${PN} += "agl-qemu-runner"