Update github.com git:// SRC_URIs
[AGL/meta-agl-demo.git] / recipes-config / cluster-lin-bridging-config / cluster-lin-bridging-config.bb
1 DESCRIPTION = "Configure LIN to external CAN bridging"
2 LICENSE = "MIT"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4
5 SRC_URI = "\
6     file://cluster-lin-bridging.service \
7 "
8
9 inherit systemd
10
11 SYSTEMD_PACKAGES = "${PN}"
12 SYSTEMD_SERVICE:${PN} = "cluster-lin-bridging.service"
13 SYSTEMD_AUTO_ENABLE:${PN} = "enable"
14
15 do_configure[noexec] = "1"
16 do_compile[noexec] = "1"
17
18 do_install() {
19     install -d ${D}${systemd_system_unitdir}
20     install -m 0644 ${WORKDIR}/cluster-lin-bridging.service ${D}${systemd_system_unitdir}
21 }
22
23 FILES:${PN} += "${systemd_system_unitdir}"
24
25 RDEPENDS:${PN} = " \
26         can-utils \
27         sllin \
28 "