Add virtual sllin support and LIN bridging to CAN for demos
[AGL/meta-agl-demo.git] / recipes-config / cluster-lin-bridging-config / cluster-lin-bridging-config.bb
1 DESCRIPTION = "Configure LIN to external CAN bridging"
2 LICENSE = "GPLv2"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4
5 SRC_URI = "\
6     file://cluster-lin-bridging.service \
7 "
8
9 inherit systemd
10
11 SYSTEMD_PACKAGES = "${PN}"
12 SYSTEMD_SERVICE_${PN} = "cluster-lin-bridging.service"
13 SYSTEMD_AUTO_ENABLE_${PN} = "enable"
14
15 do_configure[noexec] = "1"
16 do_compile[noexec] = "1"
17
18 do_install() {
19     install -d ${D}${systemd_system_unitdir}
20     install -m 0644 ${WORKDIR}/cluster-lin-bridging.service ${D}${systemd_system_unitdir}
21 }
22
23 FILES_${PN} += "${systemd_system_unitdir}"
24
25 RDEPENDS_${PN} = " \
26         can-utils \
27         sllin \
28         sllin-virtual \
29 "