Update demo features for switch to ondemandnavi
[AGL/meta-agl-demo.git] / recipes-config / cluster-demo-network-config / cluster-demo-network-config_1.0.bb
1 SUMMARY     = "Setting files for cluster network for the AGL Demonstrator"
2 DESCRIPTION = "Setting files for cluster network for the AGL Demonstrator"
3 LICENSE     = "MIT"
4 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5
6 inherit systemd allarch
7
8 SRC_URI = "file://cluster-demo-network-conf.service"
9
10 do_configure[noexec] = "1"
11 do_compile[noexec] = "1"
12
13 do_install() {
14     # Install cluster demo network configuration service unit
15     install -d ${D}${systemd_system_unitdir}
16     install -m 0644 ${WORKDIR}/cluster-demo-network-conf.service ${D}${systemd_system_unitdir}
17
18     # Add symlink to network.target.wants
19     install -d ${D}${sysconfdir}/systemd/system/network.target.wants
20     ln -s ${systemd_system_unitdir}/cluster-demo-network-conf.service ${D}${sysconfdir}/systemd/system/network.target.wants/
21 }
22
23 FILES_${PN} += "${systemd_system_unitdir}"