20ca1263994670e95e25b63f86781a527350610f
[AGL/meta-agl-demo.git] / recipes-config / agl-login-manager / agl-login-manager_0.1.bb
1 SUMMARY = "AGL Login manager"
2
3 LICENSE = "MIT"
4 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5
6 LOGIN_USER ??="1001 1002"
7
8 RDEPENDS:${PN} += "af-main"
9
10 do_install:append() {
11
12     install -d ${D}${systemd_system_unitdir}/multi-user.target.wants/
13
14     for AGL_USER in ${LOGIN_USER};do
15         ln -s ../afm-user-session@.service ${D}${systemd_system_unitdir}/multi-user.target.wants/afm-user-session@${AGL_USER}.service
16     done
17 }
18
19 FILES:${PN} += "${systemd_system_unitdir}"