Update meta-agl-demo for for 'Daring Dab'
[AGL/meta-agl-demo.git] / recipes-automotive / ambdbusaccess / ambdbusaccess_0.1.bb
1 SUMMARY = "ambdbusaccess"
2
3 LICENSE = "MPL-2.0"
4 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad \
5                     file://ambdbusaccess.cpp;startline=1;endline=5;md5=0ba6897a99e9332dae1891b4ccf78de3 \
6                    "
7
8 SRC_URI = "file://* \
9           "
10 S = "${WORKDIR}"
11
12 DEPENDS = "qtdeclarative qtbase"
13 RDEPENDS_${PN} = "automotive-message-broker"
14
15 RPROVIDES_${PN} = "ambdbusaccess"
16
17 inherit qmake5
18
19 do_install () {
20         install -d ${D}${libdir}/qt5/qml/Automotive/
21         install -m 0755 ambdbusaccess ${D}${libdir}/qt5/qml/Automotive/
22 }
23
24 FILES_${PN} += "${libdir}/qt5/qml/Automotive/ambdbusaccess"
25 FILES_${PN}-dbg += "${libdir}/qt5/qml/Automotive/.debug"
26