Adapt agl-service-cloudproxy dependencies
[AGL/meta-agl-demo.git] / recipes-apis / agl-service-cloudproxy / agl-service-cloudproxy_git.bb
1 SUMMARY     = "AGL cloud proxy service"
2 DESCRIPTION = "AGL cloud proxy service build with recipe method"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/apps/agl-service-cloudproxy"
4 SECTION     = "apps"
5 LICENSE     = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=34f8c1142fd6208a8be89399cb521df9"
7
8 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-cloudproxy;protocol=https;branch=${AGL_BRANCH}"
9 SRCREV = "${AGL_APP_REVISION}"
10
11 PV      = "1.0+git${SRCPV}"
12 S       = "${WORKDIR}/git/"
13
14 DEPENDS = "azure-iot-sdk-c aws-iot-device-sdk-embedded-c glib-2.0 nlohmann-json"
15
16 inherit cmake aglwgt pkgconfig
17
18 # Azure include files
19 CXXFLAGS_prepend += "-I${STAGING_INCDIR}/azureiot"
20
21 RDEPENDS_${PN} += "azure-iot-sdk-c azure-c-shared-utility aws-iot-device-sdk-embedded-c"
22
23 BBCLASSEXTEND = "native nativesdk"