SPEC-3723: restructure meta-agl-demo
[AGL/meta-agl-demo.git] / recipes-apis / agl-service-can-low-level / agl-service-can-low-level_git.bb
1 SUMMARY     = "Low level CAN service"
2 DESCRIPTION = "AGL Service application for read and decode CAN messages"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/low-level-can-service"
4 SECTION     = "apps"
5
6 LICENSE = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
8
9 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-can-low-level;protocol=https;branch=${AGL_BRANCH}"
10 SRCREV = "${AGL_APP_REVISION}"
11
12 PV = "${AGLVERSION}"
13 S  = "${WORKDIR}/git"
14
15 DEPENDS = "libafb-helpers libappcontroller"
16
17 inherit cmake aglwgt pkgconfig ptest
18
19 # For now, just enable J1939 on the qemu platforms where we know the
20 # linux-yocto kernel is new enough (>= 5.4) and has the support enabled.
21 AGLWGT_CMAKE_CONFIGURE_ARGS_append_qemuall = " -DWITH_FEATURE_J1939=ON"
22
23 RDEPENDS_${PN} = "virtual/low-can-dev-mapping"