Add example IC EG container demo image
[AGL/meta-agl-demo.git] / dynamic-layers / meta-agl-ic-container / recipes-platform / images / agl-lxc-demo-platform.bb
1 SUMMARY = "LXC host demo image"
2 LICENSE = "MIT"
3
4 require recipes-platform/images/lxc-host-image-minimal.bb
5
6 CONTAINER_IMAGES ?= "agl-container-cluster:guest-image-cluster-demo \
7                      agl-container-ivi:agl-demo-platform \
8                     "
9
10 IMAGE_INSTALL += " \
11     kernel-modules \
12     alsa-utils \
13     packagegroup-pipewire \
14     pipewire-ic-ipc \
15     wireplumber-config-agl \
16 "
17
18 # packages required for network bridge settings via lxc-net
19 IMAGE_INSTALL += " \
20     lxc-networking \
21     iptables-modules \
22     dnsmasq \
23     systemd-netif-config \
24     kernel-module-xt-addrtype \
25     kernel-module-xt-multiport \
26 "
27
28 # network manager to use
29 VIRTUAL-RUNTIME_net_manager = "systemd"
30
31 IMAGE_INSTALL:append:rcar-gen3 = " kernel-module-gles "