Restore chromium target and browser service
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo.bb
index 5f82f09..b5599ea 100644 (file)
@@ -23,10 +23,10 @@ MOST_DRIVERS_cyclone5 ?= ""
 
 # HVAC dependencies
 ###################
-LIN_DRIVERS ??= " sllin sllin-virtual"
+LIN_DRIVERS ??= " sllin"
 # These boards use different kernels - needs to be checked
-LIN_DRIVERS_dra7xx-evm ?= "sllin-virtual"
-LIN_DRIVERS_dragonboard-410c ?= "sllin-virtual"
+LIN_DRIVERS_dra7xx-evm ?= ""
+LIN_DRIVERS_dragonboard-410c ?= ""
 
 # UNICENS service
 UNICENS ?= " \
@@ -42,16 +42,8 @@ DEMO_ENABLE_BTWILINK ?= ""
 DEMO_PLATFORM_CONF = ""
 DEMO_PLATFORM_CONF_append_ulcb = "${@bb.utils.contains("DEMO_ENABLE_BTWILINK", "true", "", " btwilink-disable-conf", d)}"
 
-SMARTDEVICELINK = "${@bb.utils.contains('DISTRO_FEATURES', 'agl-sdl', \
-    'packagegroup-agl-smartdevicelink', '', d)}"
-
-# removed: now all enablers are in meta-agl-devel/meta-audio-soundmanager-framework
-# old audio package
-# AUDIO-OLD = "audiomanager"
-
 RDEPENDS_${PN} += "\
     udisks2 \
-    ${SMARTDEVICELINK} \
     "
 
 # fonts
@@ -64,6 +56,7 @@ TTF_FONTS = " \
     source-han-sans-cn-fonts \
     source-han-sans-jp-fonts \
     source-han-sans-tw-fonts \
+    source-han-sans-kr-fonts \
     "
 
 
@@ -71,8 +64,8 @@ RDEPENDS_${PN} += " \
     linux-firmware-ath9k \
     linux-firmware-ralink \
     can-utils \
+    cannelloni \
     iproute2 \
-    dhcp-client \
     ${UNICENS} \
     ${MOST_DRIVERS} \
     ${LIN_DRIVERS} \
@@ -80,5 +73,3 @@ RDEPENDS_${PN} += " \
     ${TTF_FONTS} \
     ${@bb.utils.contains('DISTRO_FEATURES', 'webruntime', 'virtual/webruntime', '', d)} \
     "
-
-