Remove virtual/webruntime RPROVIDES
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform-html5.bb
index d0c81c6..9c93b32 100644 (file)
@@ -8,30 +8,37 @@ inherit packagegroup
 PROVIDES = "${PACKAGES}"
 PACKAGES = "\
     packagegroup-agl-demo-platform-html5 \
-    packagegroup-agl-demo-platform-html5-devel \
     "
 
-ALLOW_EMPTY:${PN} = "1"
-
 RDEPENDS:${PN} += "\
     packagegroup-agl-image-ivi \
+    packagegroup-agl-demo \
     "
 
-RDEPENDS:${PN} += "\
-    packagegroup-hmi-framework \
+# TODO(jdapena): replace this with HTML5 apps.
+AGL_APPS = " \
+    html5-dashboard \
+    html5-launcher \
+    html5-homescreen \
+    html5-hvac \
+    html5-mediaplayer \
+    html5-mixer \
+    html5-settings \
+    html5-aquarium \
+    html5-youtube \
+    html5-jitsi \
+    html5-examples \
     "
 
-
 RDEPENDS:${PN}:append = " \
-    weston-ini-conf \
+    wam \
+    weston-ini-conf-landscape-no-activate \
     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
+    qtquickcontrols2-agl \
+    qtquickcontrols2-agl-style \
+    ${AGL_APPS} \
     "
 
-# NOTE: Currently no coverage versions for the application widgets,
-#       they should be added here when available.
-#       Also, the navigation and mixer debug widgets are currently
-#       specified explicitly, as there's no simple way to derive their
-#       names from the virtual/ RPROVIDES at present.
-RDEPENDS:${PN}-devel = " \
-    packagegroup-hmi-framework-devel \
-    "
+# nss-agl-driver-db is required to connect to kuksa
+RDEPENDS:${PN}:append = " nss-agl-driver-db "
+