Remove virtual/webruntime RPROVIDES
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform-html5.bb
index ac82d73..9c93b32 100644 (file)
@@ -1,34 +1,44 @@
-SUMMARY = "The software for DEMO platform of AGL HTML5 profile"
-DESCRIPTION = "Packages required to demo the HTML5 profile and sample web apps"
+SUMMARY = "The software for DEMO platform of AGL IVI profile"
+DESCRIPTION = "A set of packages belong to AGL Demo Platform"
 
 LICENSE = "MIT"
 
 inherit packagegroup
 
+PROVIDES = "${PACKAGES}"
 PACKAGES = "\
     packagegroup-agl-demo-platform-html5 \
     "
 
-ALLOW_EMPTY:${PN} = "1"
-
 RDEPENDS:${PN} += "\
     packagegroup-agl-image-ivi \
-    packagegroup-agl-profile-graphical-html5 \
     packagegroup-agl-demo \
     "
 
+# TODO(jdapena): replace this with HTML5 apps.
 AGL_APPS = " \
-    html5-homescreen \
+    html5-dashboard \
     html5-launcher \
+    html5-homescreen \
     html5-hvac \
-    html5-settings \
-    html5-mixer \
     html5-mediaplayer \
-    html5-dashboard \
-    html5-background \
+    html5-mixer \
+    html5-settings \
+    html5-aquarium \
+    html5-youtube \
+    html5-jitsi \
+    html5-examples \
     "
 
 RDEPENDS:${PN}:append = " \
-    weston-ini-conf-landscape \
+    wam \
+    weston-ini-conf-landscape-no-activate \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
+    qtquickcontrols2-agl \
+    qtquickcontrols2-agl-style \
     ${AGL_APPS} \
     "
+
+# nss-agl-driver-db is required to connect to kuksa
+RDEPENDS:${PN}:append = " nss-agl-driver-db "
+