Update License filename
[AGL/meta-agl-cluster-demo.git] / recipes-platform / packagegroups / packagegroup-agl-cluster-demo-platform.bb
index d639495..2ca89e4 100644 (file)
@@ -13,41 +13,31 @@ ALLOW_EMPTY_${PN} = "1"
 
 RDEPENDS_${PN} += "\
     packagegroup-agl-profile-cluster-qt5 \
+    packagegroup-agl-ttf-fonts \
+    packagegroup-agl-source-han-sans-ttf-fonts \
+    packagegroup-agl-networking \
     "
 
-# fonts
-TTF_FONTS = " \
-    ttf-bitstream-vera \
-    ttf-dejavu-sans \
-    ttf-dejavu-sans-mono \
-    ttf-dejavu-serif \
-    source-han-sans-cn-fonts \
-    source-han-sans-jp-fonts \
-    source-han-sans-tw-fonts \
-    "
 
 AGL_APPS = " \
     cluster-dashboard \
     cluster-receiver \
+    qt-cluster-receiver \
     "
 
 AGL_APIS = " \
-    agl-service-windowmanager \
+    agl-service-can-low-level \
+    agl-service-gps \
+    agl-service-signal-composer \
     "
 
+DEMO_PRELOAD = "${@bb.utils.contains("DISTRO_FEATURES", "agl-cluster-demo-preload", "cluster-dashboard-demo-config", "",d)}"
+
 RDEPENDS_${PN}_append = " \
-    wayland-ivi-extension \
-    cluster-windowmanager-conf \
     hmi-debug \
-    libva-utils \
+    can-utils \
     linux-firmware-ralink \
-    connman \
-    connman-client \
-    connman-tools \
-    cluster-connman-conf \
-    iproute2 \
-    dhcp-client \
-    ${TTF_FONTS} \
     ${AGL_APPS} \
     ${AGL_APIS} \
+    ${DEMO_PRELOAD} \
 "