meta-agl-demo: recipes-kernel: update MOST driver recipes
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-demo-platform.bb
index a40680d..ff64f13 100644 (file)
@@ -15,11 +15,70 @@ IMAGE_INSTALL_append = " \
     packagegroup-agl-demo-platform \
     "
 
-# add packages for CES2016 demo
+# fonts
+IMAGE_TTF_FONTS = " \
+    ttf-bitstream-vera \
+    ttf-dejavu-sans \
+    ttf-dejavu-sans-mono \
+    ttf-dejavu-serif \
+    "
+
+# add packages for CES2017 demo
+# Only for porter as these kernel module sources
+# are for the 3.10.x kernel only
+MOST_DRIVERS = " "
+MOST_DRIVERS_append = " \
+    aim-cdev \
+    aim-network \
+    aim-sound \
+    aim-v4l2 \
+    hdm-dim2 \
+    hdm-i2c \
+    hdm-usb \
+    mocca-usb \
+    mostcore \
+    "
+
+# HVAC dependencies depend on drivers above
+IMAGE_MOST_HVAC = " "
+IMAGE_MOST_HVAC_append = " \
+    ${MOST_DRIVERS} \
+    unicens \
+    vod-server \
+    "
+
+# can-lin is a binary and only for porter :(
+IMAGE_MOST_HVAC_append_porter = " \
+    can-lin \
+    "
+
+# mapviewer and mapviewer-demo requires AGL CES2017 demo mock-up
+IMAGE_MAPVIEWER = " "
+IMAGE_MAPVIEWER_append_porter = " \
+    mapviewer \
+    mapviewer-demo \
+    "
+
+IMAGE_AGL_APPS = " \
+    hvac \
+    mediaplayer \
+    mixer \
+    navigation \
+    settings \
+    "
+
 IMAGE_INSTALL_append = " \
-    CES2016-demo \
-    can-utils iproute2 \
+    ces2017-demo \
+    linux-firmware-ath9k \
+    linux-firmware-ralink \
+    can-utils \
+    iproute2 \
     python-curses \
     dhcp-client \
-    climatecontrolplugin \
+    navigation \
+    poiapp \
+    ${IMAGE_MAPVIEWER} \
+    ${IMAGE_MOST_HVAC} \
+    ${IMAGE_AGL_APPS} \
+    ${IMAGE_TTF_FONTS} \
     "