Allow SRCREV handling through poky-agl.conf
[AGL/meta-agl-demo.git] / recipes-kernel / mocca-usb / mocca-usb.bb
index 59bcf7a..cf4e585 100644 (file)
@@ -1,4 +1,4 @@
-DESCRIPTION = "Example of how to build an external Linux kernel module"
+DESCRIPTION = "Build USB driver for MOCCA box"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
@@ -6,7 +6,7 @@ inherit module
 
 PV = "0.1"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/can-lin/;protocol=https"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/can-lin/;protocol=https;branch=${AGL_BRANCH}"
 S = "${WORKDIR}/git/Usb-Driver"
 SRCREV = "02ba272c0eb51b06160307b6cb71f91684772c8c"
 
@@ -20,6 +20,3 @@ do_install_append () {
         echo "mocca_usb" > ${D}${sysconfdir}/modules-load.d/mocca_usb.conf
     fi
 }
-
-# These sources are currently for the porter kernel only
-COMPATIBLE_MACHINE = "porter"