kernel: most: add mostcore module dependencies
[AGL/meta-agl-demo.git] / recipes-kernel / hdm-usb / hdm-usb.bb
index 603ea32..df45e37 100644 (file)
@@ -1,22 +1,24 @@
-DESCRIPTION = "Example of how to build an external Linux kernel module"
+DESCRIPTION = "Build USB adapter driver for MOST"
 LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
-                   file://hdm_usb.c;md5=ff660625252cda55e5bc409632fc8a78 \
-                  "
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+DEPENDS = " mostcore"
 
 inherit module
 
-PR = "r0"
 PV = "0.1"
 
-SRC_URI = "file://Makefile \
-          file://../../aim-network/files/networking.h \
-          file://../../mostcore/files/mostcore.h \
-          file://hdm_usb.c \
-          file://COPYING \
-         "
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
 
-S = "${WORKDIR}"
+S = "${WORKDIR}/git/driver/${PN}"
+SRCREV = "${AUTOREV}"
 
 # The inherit of module.bbclass will automatically name module packages with
 # "kernel-module-" prefix as required by the oe-core build environment.
+
+do_install_append () {
+    # modprobe automatically at boot
+    if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+        install -d ${D}${sysconfdir}/modules-load.d
+        echo "hdm_usb" > ${D}${sysconfdir}/modules-load.d/hdm_usb.conf
+    fi
+}