kernel: most: add mostcore module dependencies
[AGL/meta-agl-demo.git] / recipes-kernel / hdm-dim2 / hdm-dim2.bb
index 438117a..a917929 100644 (file)
@@ -1,31 +1,24 @@
-DESCRIPTION = "Example of how to build an external Linux kernel module"
+DESCRIPTION = "Build DIM2 adapter driver for MOST"
 LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
-                   file://dim2_hdm.c;md5=263233c0fde1611b5b416f415bd3594d \  
-                   file://dim2_hal.c;md5=9ae71bc76a4a056593eec2efc5703f50 \
-                   file://dim2_sysfs.c;md5=d66a0b6e9b3979d18653029d1cb4c362 \  
-                  "
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+DEPENDS = " mostcore"
 
 inherit module
 
-PR = "r0"
 PV = "0.1"
 
-SRC_URI = "file://Makefile \
-          file://../../mostcore/files/mostcore.h \
-          file://../../aim-network/files/networking.h \
-          file://dim2_hal.h \
-          file://dim2_hdm.h \
-          file://dim2_sysfs.h \
-          file://dim2_reg.h \
-          file://dim2_errors.h \
-          file://dim2_hdm.c \
-          file://dim2_hal.c \
-          file://dim2_sysfs.c \
-          file://COPYING \
-         "
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
 
-S = "${WORKDIR}"
+S = "${WORKDIR}/git/driver/${PN}"
+SRCREV = "${AUTOREV}"
 
 # The inherit of module.bbclass will automatically name module packages with
 # "kernel-module-" prefix as required by the oe-core build environment.
+
+do_install_append () {
+    # modprobe automatically at boot
+    if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+        install -d ${D}${sysconfdir}/modules-load.d
+        echo "hdm_dim2" > ${D}${sysconfdir}/modules-load.d/hdm_dim2.conf
+    fi
+}