kernel: most: add mostcore module dependencies
[AGL/meta-agl-demo.git] / recipes-kernel / aim-cdev / aim-cdev.bb
index e2b0bbe..e8c101e 100644 (file)
@@ -1,21 +1,24 @@
-DESCRIPTION = "Example of how to build an external Linux kernel module"
+DESCRIPTION = "Build character device driver for MOST"
 LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
-                   file://cdev.c;md5=b080105073061d6c4f25e3c2daab2d12 \
-                  "  
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+DEPENDS = " mostcore"
 
 inherit module
 
-PR = "r0"
 PV = "0.1"
 
-SRC_URI = "file://Makefile \
-          file://../../mostcore/files/mostcore.h \
-          file://cdev.c \
-          file://COPYING \
-         "
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
 
-S = "${WORKDIR}"
+S = "${WORKDIR}/git/driver/${PN}"
+SRCREV = "${AUTOREV}"
 
 # The inherit of module.bbclass will automatically name module packages with
 # "kernel-module-" prefix as required by the oe-core build environment.
+
+do_install_append () {
+    # modprobe automatically at boot
+    if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+        install -d ${D}${sysconfdir}/modules-load.d
+        echo "aim_cdev" > ${D}${sysconfdir}/modules-load.d/aim_cdev.conf
+    fi
+}