Upgrade to pyro
[AGL/meta-agl-demo.git] / recipes-graphics / wayland / weston_%.bbappend
index b6990cc..c6979e0 100644 (file)
@@ -1,12 +1,11 @@
-FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 
-SRC_URI_append = "\
-    file://0001-weston-patch-for-wl-shell-emulator.patch \
-    file://0001-ivi-shell-fix-TODO-which-expects-only-one-screen-in-.patch \
-    file://0002-ivi-shell-avoid-inserting-a-ivi_layer-to-multiple-sc.patch \
-    file://0003-ivi-shell-fix-layout_layer.view_list-is-not-initiliz.patch \
-    file://0004-ivi-shell-remove-a-code-which-expects-only-a-screen-.patch \
-    file://0005-ivi-shell-multi-screen-support.-ivi_layout_screen-to.patch \
-    file://0006-ivi-shell-transforming-from-a-single-screen-coordina.patch \
-    file://0007-RFR-ivi-shell-multi-screen-support-to-calcuration-of.patch \
-    "
+SRC_URI_append_m3ulcb = " \
+    file://0001-Add-virtual-output-support.patch \
+    file://0002-Add-gst-recorder-for-h264-output-streaming.patch \
+    file://0003-gst-recorder-Use-USERPTR-instead-of-DMABUF-for-VSP-o.patch \
+    file://0004-gst-record-Specify-bytesused-and-length-of-VSP-input.patch \
+    file://0005-gst-record-switch-to-gettime-function-to-CLOCK_MONOT.patch \
+"
+
+DEPENDS_append_m3ulcb = " gstreamer1.0-plugins-base"