Allow SRCREV handling through poky-agl.conf
[AGL/meta-agl-demo.git] / recipes-demo-hmi / vod-server / vod-server_0.1.bb
index 949509d..73b7fb7 100644 (file)
@@ -6,15 +6,30 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425
 
 PV = "0.1"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/vod-server;protocol=https"
-SRC_URI += "file://0001-Fix-cross-compilation-with-yocto.patch"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/vod-server;protocol=https;branch=${AGL_BRANCH}"
+SRC_URI += "file://0001-Fix-cross-compilation-with-yocto.patch \
+            file://vod-demo.service"
 
 S = "${WORKDIR}/git"
 #SRCREV = "8c5f2324d7aa61669324aec1a0ad091fe1379489"
-SRCREV = "${AUTOREV}"
+SRCREV = "${AGL_DEFAULT_REVISION}"
 
 do_install() {
-        install -m 0755 -d ${D}${bindir} 
-       install -m 0755 ${S}/VideoOnDemand ${D}${bindir}/VideoOnDemand
+        install -m 0755 -d ${D}${bindir}
+        install -m 0755 ${S}/VideoOnDemand ${D}${bindir}/VideoOnDemand
+
+        # Install VOD server systemd service (user)
+        if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+            install -m 644 -p -D ${WORKDIR}/vod-demo.service ${D}${systemd_user_unitdir}/vod-demo.service
+
+            # Execute install manually for root user on behalf of systemctl script
+            # because it doesn't support user mode of systemd.
+            install -m 0755 -d ${D}/home/root/.config/systemd/user/default.target.wants/
+            ln -sf ${systemd_user_unitdir}/vod-demo.service ${D}/home/root/.config/systemd/user/default.target.wants/vod-demo.service
+        fi
 }
 
+FILES_${PN} += " \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/vod-demo.service', '', d)} \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '/home/root/.config/systemd/user/default.target.wants/vod-demo.service', '', d)} \
+    "