Fix errors in Phone application dependency
[AGL/meta-agl-demo.git] / recipes-demo-hmi / phone / phone_git.bb
index 191f3e5..7a9f628 100644 (file)
@@ -13,6 +13,14 @@ PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
 # build-time dependencies
-DEPENDS += "qtquickcontrols2 homescreen"
+DEPENDS += "qtquickcontrols2 \
+            qtmultimedia \
+            libqtappfw \
+            virtual/libhomescreen \
+            qlibwindowmanager \
+"
 
 inherit qmake5 aglwgt
+
+RDEPENDS_${PN} += "agl-service-bluetooth agl-service-bluetooth-pbap \
+                   qtmultimedia"