Hotfix : Correct navigation dependency
[AGL/meta-agl-demo.git] / recipes-demo-hmi / navigation / navigation_git.bb
index 6c8195a..bc62ef4 100644 (file)
@@ -12,7 +12,8 @@ DEPENDS = " \
           wayland libdbus-c++ af-main \
           "
 
-RDEPENDS_${PN} = " flite openjtalk "
+RDEPENDS_${PN} = " flite openjtalk glib-2.0 freetype sqlite3 wayland zlib expat openssl \
+                   wayland libdbus-c++ af-main "
 
 SRCREV="c6403c1147fa53cd6a638f738d270c5d3bb214cf"
 SRC_URI="git://github.com/AGLExport/gpsnavi.git;branch=agl \
@@ -37,6 +38,14 @@ do_compile_prepend() {
 }
 
 do_install_append() {
+   # Attention: BUG: app ships native lib as part of platform
+   # see SPEC-785 and SPEC-384
+   # /start FIXME __________________
+     cd ${B}
+     oe_runmake 'DESTDIR=${D}' install
+     rm ${D}/usr/bin/navi
+   # /end   FIXME ^^^^^^^^^^^^^^^^^^^
+
    install -d ${D}/usr/AGL/apps
    mkdir -p ${B}/package/
    mv ${B}/navigation.wgt ${B}/package/