Temporarily fix the navigation app until SPEC-384 and SPEC-785 are fixed
[AGL/meta-agl-demo.git] / recipes-demo-hmi / navigation / navigation_git.bb
old mode 100755 (executable)
new mode 100644 (file)
index 2bdd1cc..70afe97
@@ -14,18 +14,20 @@ DEPENDS = " \
 
 RDEPENDS_${PN} = " flite openjtalk "
 
-SRCREV="3dc643168cfa8ea0028b53770351a1fa608265c1"
+SRCREV="c6403c1147fa53cd6a638f738d270c5d3bb214cf"
 SRC_URI="git://github.com/AGLExport/gpsnavi.git;branch=agl \
          file://flite.in \
          file://jtalk.in \
          file://download_mapdata_jp.sh \
          file://download_mapdata_uk.sh \
+         file://0001-Makefile-compatible-aglwgt.patch \
 "
 
 # To avoid C++ library link failure
 SECURITY_CFLAGS = ""
 
 inherit autotools pkgconfig
+inherit aglwgt
 
 S = "${WORKDIR}/git"
 
@@ -35,12 +37,26 @@ do_compile_prepend() {
 }
 
 do_install_append() {
+   # Attention: BUG: app ships native lib as part of platform
+   # see SPEC-785 and SPEC-384
+   # /start FIXME __________________
+     cd ${B}
+     oe_runmake 'DESTDIR=${D}' install
+     rm ${D}/usr/bin/navi
+   # /end   FIXME ^^^^^^^^^^^^^^^^^^^
+
    install -d ${D}/usr/AGL/apps
-   install -m 0644 ${B}/navigation.wgt ${D}/usr/AGL/apps/
+   mkdir -p ${B}/package/
+   mv ${B}/navigation.wgt ${B}/package/
    install -m 0755 ${WORKDIR}/download_mapdata_jp.sh ${D}/usr/AGL/apps/
    install -m 0755 ${WORKDIR}/download_mapdata_uk.sh ${D}/usr/AGL/apps/
 
    install -d ${D}/var/mapdata
 }
+#it's Workaround
+EXTRA_WGT_POSTINSTALL = "\
+        cyad -s -k MANIFESTS -t allow -c User::App::navigation -u '*' -p 'http://tizen.org/privilege/internal/dbus';\
+        cyad -s -k MANIFESTS -t allow -c User::App::poi -u '*' -p 'http://tizen.org/privilege/internal/dbus';\
+"
 
-FILES_${PN} += " /usr/AGL/apps/* /var/mapdata "
+FILES_${PN} += " /usr/AGL/apps/*.sh /var/mapdata "