Change libhomescreen-2017 to libhomescreen
[AGL/meta-agl-demo.git] / recipes-demo-hmi / mixer / mixer_git.bb
index f0ca5d9..b721970 100644 (file)
@@ -6,13 +6,22 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mixer;protocol=http"
-SRCREV  = "${AUTOREV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mixer;protocol=https;branch=${AGL_BRANCH}"
+
+# 'legacy' version (eel_5.0.3 == master for CES'18) when 4A is not enabled
+SRCREV  = "d9bb450ee8898cb810027897a32afd3adcb05d9f"
 
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
-inherit qmake5 aglwgt
-
 # build-time dependencies
-DEPENDS += "qtquickcontrols2 pulseaudio"
+DEPENDS += "qtquickcontrols2 \
+            pulseaudio \
+            libhomescreen \
+            qlibwindowmanager \
+"
+
+PROVIDES += "virtual/mixer"
+RPROVIDES_${PN} += "virtual/mixer"
+
+inherit qmake5 aglwgt