Change libhomescreen-2017 to libhomescreen
[AGL/meta-agl-demo.git] / recipes-demo-hmi / mixer / mixer_git.bb
index c7f30a1..b721970 100644 (file)
@@ -1,34 +1,27 @@
 SUMMARY     = "Mixer for CES2017 AGL Demonstration"
 DESCRIPTION = "AGL HMI application for control of PulseAudio mixer elements"
 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/mixer"
-LICENSE     = "Apache-2.0"
 SECTION     = "apps"
 
-PV = "1.0+git${SRCPV}"
-S  = "${WORKDIR}/git"
-
-inherit qmake5
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-DEPENDS += "qtquickcontrols2"
-# 'wgtpkg-pack' in af-main-native is required.
-DEPENDS += "af-main-native"
-DEPENDS += "pulseaudio"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mixer;protocol=https;branch=${AGL_BRANCH}"
 
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+# 'legacy' version (eel_5.0.3 == master for CES'18) when 4A is not enabled
+SRCREV  = "d9bb450ee8898cb810027897a32afd3adcb05d9f"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mixer;protocol=http"
-SRCREV  = "${AUTOREV}"
+PV = "1.0+git${SRCPV}"
+S  = "${WORKDIR}/git"
 
-RDEPENDS_${PN} += " \
-    qtmultimedia-qmlplugins \
-    qtquickcontrols2-qmlplugins \
-    "
+# build-time dependencies
+DEPENDS += "qtquickcontrols2 \
+            pulseaudio \
+            libhomescreen \
+            qlibwindowmanager \
+"
 
-do_install() {
-    install -d ${D}/usr/AGL/apps
-    install -m 0644 ${B}/package/${PN}.wgt ${D}/usr/AGL/apps/
-}
+PROVIDES += "virtual/mixer"
+RPROVIDES_${PN} += "virtual/mixer"
 
-FILES_${PN} += "/usr/AGL/apps/ \
-    /usr/AGL/apps/${PN} \
-    "
+inherit qmake5 aglwgt